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LABORATORY WORK № 1.  

ESSENTIALS OF VISUAL BASIC 

Summary 

Visual Basic (VB) (Visual Basic for Applications (VBA)) environment. Writing 

and launching programs. Debugging. 

 

Task 

1. Run MS Excel. 

2. Ribbon > RIGHT CLICK > Настройка ленты (Adjusting). 

3. Select Основные вкладки (Main Tabs) > Разработчик (Developer). Press 

OK. 

4. Ribbon > Разработчик (Developer) > Visual Basic. 

5. Insert > Module (find Module1 in Project Explorer, find Module1 in Work 

space and in Title of VBA window). 

6. Insert > Module (find Module2 in Project Explorer, find Module2 in Work 

space). 

7. DOUBLE CLICK on Module1 in Project Explorer (find changes in the Title of 

VBA window). 

8. RIGHT CLICK on Module2 in Project Explorer > Remove Module2 > 

…Export...? > Нет (No). 

9. Title of Project Explorer > Закрыть (Close). 

10. View > Project Explorer. 

11. Find that Title of VBA window has name Module1 and then write following 

program code in Work space. 

Sub program_1() 

Dim n As Double 

Dim s As Variant 
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n=1 

n=n+3 

s=Inputbox("Input any number") 

n=(n+s)/2 

Msgbox ("Average value = " & n) 

End Sub 

12. File > Save Книга1 (WorkBook1) > Select location (D:/Student/…) > 

Type any Имя файла (File Name) > Set Тип файла (File type) as "Книга Excel 

с поддержкой макросов xlsm" (Excel WorkBook with including of macros). 

Press OK. 

13. Close VBA window. 

14. Ribbon > Разработчик (Developer) > Код (Code) > Безопасность 

макросов (Macros safety). Select variant Отключить все макросы с 

уведомлением (Blocking macros with notification). Press OK. 

15. Close MS Excel. 

16. Find and open your last created Excel file. 

17. Press Включить содержимое (Macros enabled) in alert notification. 

18. Ribbon > Разработчик (Developer) > Visual Basic. 

19. DOUBLE CLICK on Module1 in Project Explorer to open it in work space 

(if it has not happened automatically). 

20. Put cursor in any place of program and choose Run button on toolbar (or Run 

> Run Sub (F5)). 

21. Write 5 in open dialog – this is your program. Press OK. 

22. See the next window – with result message ("Average value = 4,5"). Press 

OK. 

23. Put cursor in any place of program and run step by step launch – Debug > Step 

Into (F8). 
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24. Follow the active row of program code and do next steps (F8). During this 

process put mouse pointer above the variables (n, s) in code to see the tooltips with 

current values. 

25. Do F8 to the end of program. Last line (End Sub) will become white-color 

after yellow. 

26. Put cursor behind the n-variable in code and use RIGHT CLICK > Add Watch. 

27. Control the text n in Add Watch dialog. Press OK. 

28. See the name of n-variable in Watch (Watches) Window (to show/hide Watch 

(Watches) Window use View > Watch Window). 

29. Repeat pos. 26-28 for s-variable. 

30. Put cursor in program, do F8 and follow the changes of variables in Watch 

Window. Do F8 till the end of program. 

31. Change the active row n=(n+s)/2 to n=(n+s)/0. 

32. Run program (see pos. 20). 

33. Write 5 in open dialog. Press OK. 

34. Read the message in Error Dialog and select Debug. 

35. Change the row n=(n+s)/0 to n=(n+s)/2 and do Run > Continue. 

36. Run program. 

37. Write five in open dialog. Press OK. 

38. Read the message in Error Dialog and select Debug. 

39. See the error place and the value of s-variable in Watch Window. 

40. Run > Reset (we can't fix this error during runtime) 

41. Close VBA window and save file. 

42. Ribbon > Разработчик (Developer) > Код (Code) > Макросы (Macros). 

43. Select program_1 in list and press Выполнить (Run). 
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Report 

1. Write work title with number, your name (first & last) and name of your group. 

2. Answer the following questions (in writing, without text of questions): 

a) How to open Visual Basic (VB/VBA) environment in MS Excel? 

b) How to add module in VBA project? 

c) How to show/hide Project Explorer? 

d) How to save Excel file with macros? 

e) How to run VB-program? 

f) How to run program in step by step mode? 

g) How we can follow the value of variable (expression) during runtime? 

h) Describe the typical sequence to fix errors in program code. 
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LABORATORY WORK № 2.  

VARIABLES. OPERATORS. BUILT-IN FUNCTIONS 

Summary 

Basic structure of Visual Basic (VB) (Visual Basic for Application (VBA)) 

programs. Using of variables, math and text operators and functions. 

 

Table of build-in VB (VBA) operators and functions 

Operator/F

unction 

Purpose Syntax 

Math 

+ Addition <number1>+<number2> 

– Subtraction <number1>–<number2> 

* Multiplication <number1>*<number2> 

/ Division <number1>/<number2> 

\ Exact Division <number1>\<number2> 

result –  the whole part from division 

mod Remainder of the division <number1> mod <number2>  

^ Power <number1> ^ <number2> 

number1 to number2 power 

(for number1<0, number2 must be integer) 

Abs Absolute value of a number Abs(<number>) 

Returns Null for not numbers 

Atn Arctangent of a number Atn (<number>) 

Returns angle in radians [- /2 до + /2] 

Arccos(<number>)=Atn(–<number>*Sqr(–

<number> * <number>+1))+2*Atn(1), 

range for number: (-1..1) 

Cos Cosine Cos(<number>) 

Returns value in range [–1… +1]; 

number – radian value 
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Exp Exhibitor of number Exp(<number>) 

Returns e
number

 

Fix, Int Getting of entire part of a 

number 

Fix(<number>); Int(<number>) 

Fix(1.7) returns 1; 

Int(1.7) returns 1; 

Fix(-1.7) returns -1; 

Int(-1.7) returns -2; 

Fix(-1.2) returns -1; 

Int(-1.2) returns -2; 

Log Natural logarithm of a number Log(<number>) 

number > 0; 

Logxy=Log(y)/Log(x) 

Rnd Random value random value from the range [0;1) 

Sgn Number sign Sgn(<number>) 

returns 1 for number>0; 

return 0 for number=0; 

returns -1 for number<0 

Sin Sine Sin (<number>) 

Returns value in range [–1… +1]; 

number – radian value 

Sqr Root from a number Sqr(<number>) 

number >=0 

Tan Tangent Tan(<number>) 

number – radian value 

Logical 

And Logical 'And' <logical value1> And <logical value2> 

True And True – returns True; 

True And False – returns False; 

False And False – returns False 

Or Logical 'Or' <logical value1> And <logical value2> 

True Or True – returns True; 

True Or False – returns True; 

False Or False – returns False 
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Not Logical 'Not' Not <logical value> 

Not True – returns False; 

Not False – returns True 

<, >, >=, 

<=, <> 

Comparison operators <number1> < <number2> 

if number1 < number2 – returns True; 

if number1 >=  number2 – returns False 

Date 

Now Getting current date Now() 

Year Getting year from the date Year(<date>) 

Month Getting month (sequence 

number) from the date 

Month(<date>) 

Day Getting day (sequence 

number)  from the date 

Day(<date>) 

Hour Getting hour from the date Hour(<date>) 

Minute Getting minute from the date Minute(<date>) 

Second Getting second from the date Second(<date>) 

Text 

& 

оператор 

Connection of text strings <string1> & <string2> ... & <stringN> 

UCase Converts string to upper case UCase(<string>) 

LCase Converts string to lower case LCase(<string>) 

InStr Execute search of one string in 

another one 

InStr(<string1>,<string2>) 

returns first position of string1 in string2;  

without result – returns 0 

Left Returns of specified number 

of symbols from the start of 

string 

Left(<string>,<number of symbols>) 

Right Returns of specified number 

of symbols from the end of 

string 

Right(<string>,<number of symbols>) 

Mid Returns specified number of 

symbol form the specified 

position from string 

Mid(<string>,<number1>,[<number2>]) 

string – source string; 

number1 – start position; 
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number2 – number of symbols; 

if number2 omitted – till the end of string 

LTrim Delete all space-symbols from 

the start of string 

LTrim(<string>) 

RTrim Delete all space-symbols from 

the end of string 

RTrim(<string>) 

Trim Delete all space-symbols from 

the both sides of string 

Trim(<string>) 

Len Returns quantity of symbols in 

text string 

Len(<string>) 

Chr Returns of symbol by its 

ASCII-code 

Chr(<ASCII-code>) 

Chr(13) – returns Enter - text command 

Asc Returns of ASCII-code by its 

symbol  

Asc(<symbol>) 

 

Example 

Part 1  

Make algorithm for expression calculation: 

]6..2[rangethefromrandom)B(arctg

B01,0100

)))Asin(3/(D(devisiontheofremainder
divisiontheofpartwhole1

F

C





















 

Write VB-program for this algorithm. The value of arguments A and B must be 

typed during runtime.    

Solving for Part 1 

Algorithm for expression calculation: 
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Program for this algorithm: 

Sub program_1() 

Dim A As Double 

Dim B As Double 

Dim C As Double 

Dim D As Double 

Dim PI As Double 

Dim FR As Double 

Dim F As Double 

A 

B 

F 

C=3.5 

D=6 

PI=arctg(1)*4 

))180/PI*Asin(3/(D(divisiontheofremainderF   













CB01,0100

F
divisiontheofpartwholeF  

F=1-F 

finish 

start 

FR)B(arctg

F
F


  

FR = random from the range [2..6] 
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A = InputBox("Input number in variable 'A':") 

B = InputBox("Input number in variable 'B':") 

C = 3.5 

D = 6 

PI = Atn(1) * 4 

F = D Mod (3 + Sin(A * PI / 180)) 

F = F \ (100 + 0.01 * (B ^ C)) 

F = 1 – F 

FR=Rnd() * 4 + 2 

F = F / (Atn(Sqr(B))+FR) 

MsgBox "F = " & F 

End Sub 

Results: 

 

  

Part 2 

We need to construct string which consists of following parts: 1) the string S 

without the second and the last symbol; 2) the space-symbol; 3)  the upper case 

string1 in which first two symbols replaced by the two symbols which ASCII-
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codes are 117 and 112; 4) the string – sum of current value of seconds and ASCII-

code of symbol "q". String S must be typed during runtime. 

Solving for Part 2 

Algorithm for task solving: 

 

S 

< Inputting value into the S-variable 

> S1 = Left(S, 1) & Mid(S, 3, Len(S) - 3) 

< Connection of the first symbol with sequence from the third till  

the penultimate symbol of the string > 

start 

S1 & S2 & S3 & S4 

<Connection of result string 

and display it in dialog> 

finish 

S2 = " " 

< Definition of space-symbol > 

S3 = Chr(117) & Chr(112) 

< Connection of the two symbols which ASCII-codes are 117 and 112 > 

S3 = S3 & Mid(S1, 3) 

< Connection with a part of string from its third symbol till the end > 

S3 = UCase(S3) 

< Definition of the upper case string > 

D1 = Now() 

< Getting of the current date > 

S4 = Second(D1)  

< Getting of the current value of seconds > 

S4 = S4 + Asc("q") 

< Addition to previous variable the value of ASCII-code of symbol "q" > 
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Program for this algorithm: 

Sub program_2() 

Dim S As String 

Dim S1 As String 

Dim S2 As String 

Dim S3 As String 

Dim S4 As String 

Dim D1 As Date 

S = InputBox("Specify string (for S variable):") 

S1 = Left(S, 1) & Mid(S, 3, Len(S) - 3) 

S2 = " " 

S3 = Chr(117) & Chr(112) 

S3 = S3 & Mid(S1, 3) 

S3 = UCase(S3) 

D1 = Now() 

S4 = Second(D1)  

S4 = S4 + Asc("q") 

MsgBox S1 & S2 & S3 & S4 

End Sub 

Results: 
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Task 

Part 1  

Make algorithm for expression calculation (see table of Variants). 

Write VB-program for this algorithm. The value of arguments A and B must be 

typed during runtime. 

Part 2 

We need to construct string which consists of following parts (see table of 

Variants). String S must be typed during runtime. 

Variants 

Variant 

№ 

Description 

1 Part 1 

Bln1

)D(tg)A3sin(|BA|
F








 

Part 2 1) Upper case string from the first symbol till the third symbol (inclusively) 

of string S; 3) space-symbol; 3) the string from the fourth till the last symbol 

of string S. 

2 Part 1 
DC CDe1

B

A
divisiontheofremainderF 








  

Part 2 1) The string from the second till the fourth symbol (inclusively) of string S; 

2) upper case string from the "before the penultimate" till the penultimate 

symbol of string S. 
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3 Part 1 







 










DC

|DC|
arctg

B

A
divisiontheofpartwholeF  

Part 2 1) The string which consists of ASCII-codes of first three symbols of string 

S (codes must be separated by the space-symbol); 2) upper case string which 

consists of two last symbols of string S. 

4 Part 1 
 

 3...1rangethefromrandom

)DC(arctg

B

BA
divisiontheofpartwholeF










 
  

Part 2 1) Upper case string from the first till the second symbol (inclusively) of 

string S; 2) upper case third symbol of string S; 3) ASCII-code of the last 

symbol of string S. 

5 Part 1 
|
)Ccos(

DC
|

BA1F




  

Part 2 1) The string from the second till the last symbol (inclusively) of string S; 2) 

ASCII-code of the fourth symbol of string S; 3) The string from the "before 

the penultimate" till the penultimate symbol of string S. 

6 Part 1 
D

CB
)D(ln

e

1
AF 










  

Part 2 1) ASCII-code of the last symbol of string S; 2) the string S without the 

second and the third symbols; 3) the string from the second till the 

penultimate symbol (inclusively) of string S. 

7 Part 1 

)Bcos(C

B
)A(logF

D7 
  

Part 2 1) The string S without the second and the penultimate symbol; 2) fourth 

symbol of string S; 3) sequence of three symbols, which ASCII-codes are 

109, 97, 217. 

8 Part 1 































D

B
divisiontheofpartwhole)Ccos(|D|

BA

1
F e 

 

Part 2 1) The string from the third till the fourth symbol (inclusively) of string S; 2) 

sequence of four symbols, which ASCII-codes are 115, 104, 105, 112; 3) the 

string – current value of minutes.  
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9 Part 1 

])4...2[rangethefromrandomD1(C

e
F

|B2|






 

Part 2 1) The string from the fourth till the last symbol (inclusively) of string S; 2) 

the last symbol of string S; 3) the string – the amount of symbols in string1 

and string2. 

10 Part 1 

)B(log
|1C|

A
1F 2

3D









  

Part 2 1) Sequence of four symbols, which ASCII-codes are 119, 105, 110, 103; 2) 

the string from the "before the penultimate" symbol (inclusively) till the end 

of the string S; 3) space-symbol; 4) the string S without the second and the 

third symbols. 

11 Part 1 

)1B(
))D10cos((C

A
divisiontheofremainder2F e 


























  

Part 2 1) Upper case string which consists of four symbols, which ASCII-codes are 

115, 110, 111, 119; 2) space-symbol; 3) the string S without the second 

symbol. 

12 Part 1 

]8...5[rangethefromrandom2F
))D2cos((

C

B
A


 

 

Part 2 1) The string S without the second and the last symbol; 2) the string S which 

third and fourth symbol replaced by the two symbols which ASCII-codes are 

105 and 110. 

13 Part 1 
DlogB)Acos(F |C|2

D
 

 

Part 2 1) The string – current day of month; 2) the string S in which first three 

symbols replaced by the three symbols which ASCII-codes are 99, 97 and 

116. 

14 Part 1 

DAln1F

))C/1cos((

B

A



















 

Part 2 1) The string – current value of seconds; 2) the string S without the second 

and the penultimate symbol. 
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15 Part 1 

)D(arctg)C16ln(eF B2A

1

 
 

Part 2 1) The upper case string S without three last symbols; 2) the string S in 

which last three symbols replaced by the three symbols which ASCII-codes 

are 100, 111 and 103. 

16 Part 1 
2

B

]8...6[rangethefromrandom
)Ccos(

A1
1F 













 


  

Part 2 1) The string S without the fourth and the last symbol; 2) the string – sum of 

current value of minutes and seconds; 3) the string – the length of string2. 

17 Part 1 

DC
B

1
1F e

)Asin(













 

Part 2 1) Sequence of four symbols, which ASCII-codes are 114, 97, 105, 110; the 

first and the third symbols must be in upper case; 2) the string S without the 

second, the third and the fourth symbols. 

18 Part 1 

)D(arctg
CD

A
F

)BA1(





  

Part 2 1) The string S in which last two symbols replaced by the symbols which 

ASCII-codes are 116 and 111; 2) the string – current value of hours; 3) the 

string – amount of symbols in string1. 

19 Part 1 

]3..1[rangethefromrandomD

log
F

)
C

1
B(

A






 

Part 2 1) The string S without the third and the fourth symbol; 2) the string – 

current day of month; 3) space-symbol; 4) ASCII-code of symbol "v". 

20 Part 1 

]5..3[rangethefromrandom)Cln(

1B
)Acos(F




 

 

Part 2 1) The string S in which the second symbol replaced by the symbol with 

ASCII-code value 100; 2) the string from the "before the penultimate" till the 

penultimate symbol (inclusively) of string S. 
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Report 

1. Write work title with number, your name (first & last) and name of your group. 

2. Your task. 

3. Algorithm (block-scheme). 

4. Program code (listing). 

5. Program results (scheme of dialogs with input data and calculated values). 
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LABORATORY WORK № 3.  

CONDITIONAL STATEMENTS 

Summary 

Visual Basic (VB) realization of algorithm for executing of the alternative 

sequences of actions. 

 

Example 

Part 1  

Make algorithm for expression calculation: 

xln

x2
y


  

Expression has argument limits.  

Write VB-program for this algorithm. The value of argument (x) must be typed 

during runtime.    

Solving for Part 1 

For y-function we have following argument limits. 















)0xlnand0x2(or)0xlnand0x2(.3

1x.2

0x.1

 

First limit is determined by the logarithm argument. The second limit depends on 

the division operation. Third limit is determined by the root operation 

We can mark limits on х-axis. 
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1.  

2.  

3.  or  

 

So, summary limits for y = f(x): x = (1,2].  

Algorithm for expression calculation 
xln

x2
y


 : 

 

Program for this algorithm: 

Sub program_1() 

start 

finish 

x 

x>1 and x<=2 

xln

x2
y




 

y 

Function not defined 

- 

+ 

1 2 
x 

 

x 
1 2 

1 x 

 

x 

0 
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Dim x As Double  

Dim y As Double 

x = InputBox("Input x value: ") 

If (x > 1 And x <= 2) Then  

y = Sqr((2 - x) / Log(x)) 

MsgBox "For x = " & x & " y = " & y 

Else 

MsgBox "For x = " & x & Chr(13) & "function not defined" 

End If 

End Sub 

Results: 
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Part 2 

We have graphic for y = f(x). 

 

Make algorithm and write VB-program for calculating y = f(x). The value of 

argument (x) must be typed during runtime. 

Solving for Part 2 

Function y = f(x) is unlimited and may be calculated in three ranges of x argument: 

1. x = (-∞, 0), 2. x = [0,1], 3. x = (1, +∞):  

range 1 is described by the equation: 1xy  ,  

range 2 is described by the equation 1yx 22   or 
2x1y  ,  

range 3 is described by the equation 0y  . 

Algorithm for expression y=f(x) calculation: 

y 

x 
1 

1 
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Program for this algorithm: 

Sub program_r2() 

Dim x As Double 

Dim y As Double 

x = InputBox("Input x value: ") 

Select Case x 

Case Is < 0 

y = x + 1  

Case Is <= 1 

y = Sqr(1 - x * x) 

Case Else 

y = 0 

End Select 

MsgBox "For x = " & x & " y = " & y 

End Sub 

start 

x 

2x1y   

finish 

y 

0<=x<=1 

0y   

x 

x>1 x<0 

1xy   
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Results: 

 

 

 

 

 

Task 

Part 1  

Make algorithm for expression calculation (see table of Variants). Expression has 

argument limits. Write VB-program for this algorithm. The value of argument (x) 

must be typed during runtime.   
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Part 2 

We have graphic for y = f(x) (see table of Variants). Make algorithm and write 

VB-program for calculating y = f(x). The value of argument (x) must be typed 

during runtime. 

Variants 

Variant 

№ 

Part 1 Part 2 

1 

x

1
y   

 

2 

12xx

1
y

2 
  

 

3 x1  

 

4 

x

xln
 

 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 

y 

x 
1 

1 
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5 

)x2(

1
y


  

 

6 

1x

xln
y


  

 

7 xln1y   

 

8 

2x

2x
y




  

 

9 

xln

1
y   

 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 
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10 xln)1xln(y   

 

11 

1x

1
y


  

 

12 x  

 

13 xln  

 

14 

)1x(x

1
y


  

 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 
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15 

3x

)x4ln(
y




  

 

16 

12xx

)x3ln(
y

2 


  

 

17 

2x

x
y

3


  

 

18 

)x3()2x(

2x
y




  

 

19 )x2ln()x(lny   

 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 

 y 

x 
1 

1 



31 

 

 

20 

2xx

1
y

2 
  

 

 

Report 

1. Write work title with number, your name (first & last) and name of your group. 

2. Your task. 

3. Algorithm (block-scheme). 

4. Program code (listing). 

5. Program results (scheme of dialogs with input data and calculated values). 

 

 

 y 

x 
1 

1 


