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ЭУМК как основной дидактический ресурс 

В настоящее время требования учебных стандартов требуют 

постоянного расширения объема компетенций. В этой ситуации 

преподаватель сталкивается с объективными трудностями. Количество 

информации, с которой требуется ознакомить обучающихся, стремительно 

растет, опережая объемы предусмотренных очных занятий (как правило, 

жестко лимитированных учебными планами). 

Оказавшись в такой ситуации, преподаватели в первую очередь 

пытаются модернизировать лекционные курсы, стараясь расширить их в 

ущерб развернутому изложению материала. Следующий объект внимания  

это лабораторные практикумы или перечни практических занятий. 

Расширение тематики приводит либо к потере возможности детальной 

отработки отдельных разделов дисциплин или к тому, что ряд практических 

заданий оказывается без соответствующей теоретической поддержки в курсе 

лекций. Из намечающегося "замкнутого круга" преподаватели выходят путем 

отсылки учащихся к спискам дополнительных источников, которые по идее 

должны восполнить пробелы теоретической базы. Но, как правило, 

большинство источников являются во всех смыслах тяжеловесными. 

Столкнувшись с ними, многие школьники и студенты теряются в количестве 

страниц и объеме содержащейся в них информации. Ведь умению найти 

нужную информацию в источнике, как и способности ею воспользоваться, 

тоже необходимо учиться. 

Каков же выход из этой ситуации? Видится, что он лежит в той 

плоскости, что преподаватель, как непосредственный руководитель учебного 

процесса, должен подготовить такой методический материал, который бы 

включал в себя все необходимые теоретические положения и элементы 

практики. В этой связи возникает вопрос о форме представления таких 

материалов. Исходить нужно из того, какими типами ресурсов располагает 

преподаватель. Традиционно большое количество дидактических материалов 

(конспектов, методических указаний, пособий) представляют собой 
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документы, подготовленные в текстовом процессоре. Некоторые 

преподаватели готовят презентации и комплекты иллюстраций. В некоторых 

курсах используются учебные видео. Поскольку речь идет об учебном 

процессе, то в комплект материалов имеет смысл поместить набор 

контрольных вопросов, возможно в форме тестов. Вероятно, в комплект 

материалов преподаватель также  пожелает поместить выдержки из 

необходимых источников или дать ссылки на их сетевое размещение. 

Итак, все необходимые материалы фактически представляют собой 

набор файлов (документов) различной природы. Разобраться в этом наборе 

обучающемуся будет не просто  необходимо средство организации и 

консолидации  единая оболочка для доступа к этим ресурсам. Эта оболочка 

должна обладать простым интерфейсом, удобной навигацией, поисковыми 

возможностями. Такую оболочку в настоящее время принято называть 

электронным учебно-методическим комплексом (ЭУМК) [1].   

Реализация ЭУМК может оказаться достаточно сложной, особенно для 

преподавателя, не являющегося специалистом в области информационных 

технологий. Между тем, существуют специальные программные средства для 

разработки учебных курсов пользователями, владеющими базовыми 

навыками работы на компьютере. К таким средствам относится система 

HelpNDoc [2], разработанная компанией IBE SOFTWARE. Данная система 

имеет несколько вариантов поставки, включая коммерческую, 

образовательную и свободную. Свободный вариант не имеет 

функциональных ограничений и является бесплатным для личного 

некоммерческого использования. Знакомство с HelpNDoc имеет смысл 

начать именно с этой версии. 

 

HelpNDoc: интерфейс и настройка проекта 

HelpNDoc является инструментом для генерации справочников и 

руководств в таких форматах, как chm, html, doc, pdf, epub. Интерфейс 

HelpNDoc практически аналогичен используемому в современных офисных 

пакетах. Инструменты для настройки и редактирования  курса собраны на 

вкладках ленты. В рабочем поле отображается содержимое текущего 

редактируемого раздела. Рядом с рабочим полем (по умолчанию слева) 

располагается панель структуры создаваемого ресурса ("Table of contents"). 

Контекстное меню каждого элемента содержания позволяет выполнять его 

редактирование, включая переименование разделов и изменение их 

расположения. Именно в панели структуры выбирается раздел для правки его 

содержимого в рабочем поле. Справа от рабочего поля находятся панели для 

работы с ключевыми словами ("Keywords") и используемыми в проекте 

курса медиа-материалами ("Library"). 
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По умолчанию HelpNDoc не в полной мере поддерживает кодировку 

кириллических символов. Поэтому перед началом работы необходимо задать 

соответствующие языковые настройки в окне "General Settings" 

(открывается командой "Project options" на вкладке "Home"). Также имеет 

смысл установить поддержку проверки русской орфографии, скачав и 

зарегистрировав в HelpNDoc свободно распространяемый соответствующий 

словарь стандарта OpenOffice [3]. 

 
Создание нового раздела курса начинается с выполнения команды "Add 

topic" на вкладке "Home". 
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HelpNDoc: работа с текстом, изображениями, таблицами 

Основу любого методического ресурса составляет, как правило, текст, 

для форматирования которого в HelpNDoc предназначена отдельная вкладка 

"Write". Она организована практически аналогично панели текстового 

процессора Microsoft Word.  

 
Также как в "обычном" текстовом процессоре здесь есть возможность 

выполнять простую вставку из буфера обмена, вставку текста без 

форматирования  и специальную вставку. 

 
В группах команд "Font", "Paragraph" и "Style" вкладки "Write" 

имеются специальные кнопки для вызова диалоговых окон с расширенными 

настройками параметров шрифта, абзаца, стиля. 
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Окно работы со стилями позволяет не только редактировать 

стандартные стили для их применения в разделах учебного курса, но и 

создавать новые стили, как фрагментов текста (шрифта), так и абзацев. 

 
Наибольший интерес для преподавателя, готовящего свой курс в 

HelpNDoc, скорее всего, будет представлять вкладка "Insert", содержащая 

инструменты вставки различного содержимого на страницы разделов. 

 
Вставка изображения из графического файла производится командой 

"Insert Picture". После выделения изображения для него становится 

доступной вкладка ленты "Picture Tools: Format", в которой есть 

инструменты для настройки размеров графического объекта, его 

выравнивания и задания отступов относительно окружающего текста. 
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Для добавленных таблиц доступна специальная вкладка ленты "Table 

Tools: Layout", позволяющая, как редактировать состав строк и столбцов, так 

и выполнять форматирование отдельных элементов (границ, заливок, 

внутренних отступов). 

 
 

HelpNDoc: гиперссылки, видео, глоссарий 

Для выделенного фрагмента содержимого команда "Insert > Hyperlink" 

дает возможность добавить ссылку-переход на выбранный раздел, интернет-

ресурс или указанный файл. При этом для перехода в конкретное место 

раздела, в нем следует предварительно создать метку-якорь командой "Insert 

> Insert/Remove anchor". 
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Интересный вариант навигации реализуется посредством так 

называемых "изображений-карт", добавить и отредактировать которые 

позволяет команда "Insert > Insert image map". На изображении-карте 

можно определить области, которые будут являться гиперссылками на 

заданные ресурсы. 

 
Вставка видео в качестве содержимого раздела выполняется командой 

"Insert > Insert movie". При этом предлагается выбрать необходимый 

мультимедийный файл и указать размеры контейнера для его показа. 
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Вставку содержимого из документа текстового процессора можно 

выполнять как с помощью буфера обмена, так и посредством команды 

"Insert > Insert document", которая копирует документ полностью. 

 
Для реализации интерактивных возможностей или каких-либо 

специальных вариантов содержимого разделов предназначен специальный 

блок, добавляемый командой "Insert > Insert HTML code". Этот блок 

позволяет создать, например тест для контроля знаний, определив его с 

помощью java-script и элементов html-форм [4]. 

 
К разрабатываемому курсу можно добавить перечень ключевых слов 

(указатель, глоссарий). Это средство быстрого доступа к разделам, 

содержащим сведения о наиболее важных терминах. Для того чтобы 

добавить ключевое слово или выражение в указатель, следует выделить его в 

тексте и воспользоваться командой "Home >Add keyword". Если ссылка на 

термин понадобится в других разделах, достаточно будет, находясь в них, 

установить флажок рядом с названием термина в панели "Keywords".  
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HelpNDoc: публикация ресурса 

Завершается процесс создания курса его публикацией в один из 

форматов. Настройка публикации производится командой "Home > Generate 

help". В окне "Generate documentation", выбрав в списке нужный формат, 

следует задать необходимые параметры. Например, для chm-формата ("Build 

chm documentation") необходимо указать расположение готового файла 

курса (поле "Output file") и задать кодировку имен разделов по настройкам 

проекта, установив флажок "Use project charset for topics". 

 
Для варианта публикации в формате системы html-страниц ("Build html 

documentation") помимо указания папки для результата необходимо также 

отредактировать названия элементов пользовательского интерфейса 

("Содержания", "Поиска", "Словаря"). 

Публикация в форматы, рядом с названиями которых в списке 

установлен флажок, производится командой "Generate". 
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Готовый ресурс, например в форматах chm или html, содержит 

структурированное оглавление, указатель ключевых слов, полнотекстовый 

поиск [6]. 
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Для просмотра готового html-ресурса подойдет любой современный 

браузер. Что касается chm-файлов, то их воспроизведение в операционных 

системах семейства Windows осуществляется встроенным проигрывателем 

hh [5]. Имея в виду возможность его отсутствия у пользователей, имеет 

смысл включать его в поставку учебного ресурса. При этом запуск 

необходимо chm-курса можно организовать с помощью несложного 

командного bat-файла. 

 
 

HelpNDoc: за и против 

К несомненным плюсам HelpNDoc следует отнести:  

1. Дружественный интерфейс с удобной средой верстки. 

2. Обширный набор инструментов для вставки разнообразного 

содержимого. 

3. Достаточно хороший импорт документов текстового процессора. При 

этом сохраняются практически все параметры абзацев и шрифтов, 

переносятся растровые изображения, формулы и диаграммы автоматически 

преобразуются в рисунки, таблицы сохраняют свою структуру, содержимое, 

цвета границ и заливок.  

4. Возможность публикации в большом количестве форматов. 

Нужно отметить также следующие замеченные недостатки. 

1. В некоторых текстовых окнах (например, редакторе HTML-кода) не 

доступны контекстные команды для копирования/вставки. В прочем этот 

недостаток преодолим сочетаниями клавиш (Ctrl+Insert и Shift+Insert). 

2. При вставке из текстового процессора в HelpNDoc фрагмента текста, 

содержащего формулы они преобразуются в изображения, у которых по 

умолчанию увеличивается размер. Это приводит к "размытию" формул в 

готовых курсах (chm, html). Для преодоления этой ситуации приходится 

вручную (командой "Picture Tools: Format > Reset Picture Size") сбрасывать 

размеры каждого рисунка-формулы к исходным. 

3. Еще стоит упомянуть ряд моментов, связанных с импортом 

документов: шрифт Times New Roman сбрасывается на Arial; обтекание 

рисунков устанавливает всегда на вариант "в тексте", не учитывается тип 
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линий границ в таблицах. Впрочем, эти "шероховатости" довольно легко 

исправляются инструментами форматирования HelpNDoc. 

4. Недостаточно проработан механизм создания ссылок на файлы-

вложения к проекту. Предлагается ручное размещение этих файлов в папке 

соседней с готовым файлом курса и указанием относительной ссылки на них 

(при распространении готового курса папка с необходимыми файлами 

должна передаваться вместе с курсом). Для изображений, которые 

необходимо помещать в блоки HTML "работает" также следующая 

"маленькая хитрость". Файлы картинок добавляются в библиотеку и 

вставляются на страницу раздела "невидимыми"  с размером, например 1х1 

пиксель. После этого на картинку можно сделать ссылку в HTML-коде 

(например, для рисунка r1.png, ссылка будет иметь вид <IMG 

SRC='lib/r1.png'>). 

5. В  качестве предлагаемых программой вариантов вставки видео-

файлов, практически, имеет смысл использовать только ресурсы, имеющие 

расширение swf. В прочем, в этом есть определенный смысл. Видео типа swf 

будет гарантированно воспроизводиться практически на любом компьютере 

с установленным flash-плеером, о файлах же других форматов этого сказать 

нельзя.  

6. Не смотря на возможность задания языковых параметров, поддержка 

кириллической кодировки не является всеобъемлющей. В именах якорей, 

блоках HTML, путях к файлам проекта и самих именах файлов нельзя 

применять кириллицу. 

В целом большая часть задач по интеграции разнотипного содержимого 

в единую оболочку решена разработчиками HelpNDoc на весьма достойном 

уровне. Функционал программы позволяет считать ее удобным 

инструментом современного преподавателя для создания ЭУМК. 
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